请选择 进入手机版 | 继续访问电脑版
搜索
热搜:
查看: 1191|回复: 7

as3911的一些问题

[复制链接]

3

主题

16

帖子

449

积分

中级会员

Rank: 3Rank: 3

积分
449
发表于 2015-6-8 09:34:05 | 显示全部楼层 |阅读模式
我用as3911做了个读卡器,用的是13.56Mhz的晶振,但是我的板子的天线输出的频率是6.78Mhz的正弦波,峰值8V左右,mcu_clk输出1.57Mhz,
然后一感应电子标签后,天线那边的频率变成13.56Mhz了,mcu_clk又没了,而且天线的峰值也变低了,到mV级别了,还有我用27.12Mhz的晶振,天线没有输出,MCU_CLK也没有输出
回复

使用道具 举报

53

主题

350

帖子

4万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
43013
发表于 2015-6-8 09:46:37 | 显示全部楼层
问题已转!请耐心等待~
回复 支持 反对

使用道具 举报

0

主题

43

帖子

1118

积分

版主

Rank: 7Rank: 7Rank: 7

积分
1118
发表于 2015-6-8 09:52:45 | 显示全部楼层
如果用13.56MHz需要将register 00h bit3 osc 设定为0,MCU_CLK的状态可查询00h bit1-2 out_cl1-0的状态。
回复 支持 反对

使用道具 举报

3

主题

16

帖子

449

积分

中级会员

Rank: 3Rank: 3

积分
449
 楼主| 发表于 2015-6-8 12:01:39 | 显示全部楼层
ams_Rainbow.Tia 发表于 2015-6-8 09:52
如果用13.56MHz需要将register 00h bit3 osc 设定为0,MCU_CLK的状态可查询00h bit1-2 out_cl1-0的状态。 ...

用13.56MHz的时候我已经将register 00h bit3 osc 设定为0了,MCU_clk的状态也读了,就是出现了上面所说的问题,也不知道问题出在哪里了
回复 支持 反对

使用道具 举报

0

主题

43

帖子

1118

积分

版主

Rank: 7Rank: 7Rank: 7

积分
1118
发表于 2015-6-9 17:11:13 | 显示全部楼层
这个情况看起来就是误将13.56MHz设置为27.12MHz导致,再仔细检查下SPI操作是否寄存器读写正常。另外请按照Demo板的源代码去移植,这样问题会少一些。
回复 支持 反对

使用道具 举报

3

主题

16

帖子

449

积分

中级会员

Rank: 3Rank: 3

积分
449
 楼主| 发表于 2015-6-10 15:18:02 | 显示全部楼层
ams_Rainbow.Tia 发表于 2015-6-9 17:11
这个情况看起来就是误将13.56MHz设置为27.12MHz导致,再仔细检查下SPI操作是否寄存器读写正常。另外请按照D ...

能给我提供一下DEMO板的源代码不?谢谢您了
回复 支持 反对

使用道具 举报

0

主题

43

帖子

1118

积分

版主

Rank: 7Rank: 7Rank: 7

积分
1118
发表于 2015-6-10 16:33:25 | 显示全部楼层
请联系代理商索取相关资料。
回复 支持 反对

使用道具 举报

3

主题

16

帖子

449

积分

中级会员

Rank: 3Rank: 3

积分
449
 楼主| 发表于 2015-6-11 13:05:50 | 显示全部楼层
ams_Rainbow.Tia 发表于 2015-6-10 16:33
请联系代理商索取相关资料。

好滴,谢谢您
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关闭

站长推荐上一条 /1 下一条

Archiver|手机版|小黑屋|ams社区

GMT+8, 2019-10-16 23:29 , Processed in 0.081238 second(s), 18 queries , MemCache On.

Powered by Discuz! X3.4

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表